Need help loading mac osx snow leopard

Advertisement
October 11

i just bought mac osx snow leopard and im having trouble downloading it i have a mac osx 10.4.11 but when i put the disk in it says i need an itel based mac

Advertisement

Replay

Snow Leopard and above runs only on Intel processor Mac's, not PowerPC Mac's.
Congradulations on getting a good long life out of that old Mac, it's rapid upgrade cycle now on the Intel processors for some reason.

View 3 Replies

Tags:

  1. reset dw fabrica iphone modelo a1418?
  2. 1020dead soulision
  3. ovi upgrade via terminal
  4. sony kdl 42w805a netflix problem
  5. application nokia rm-243 6120c(b20.01)
  6. hp g60 diskpart uefi
  7. KE30 and SAP
  8. ME_PROCESS_PO_CUST BAPI_PO_CREATE1
  9. f110 RFFOEDI1
  10. B8T1
Copyrights 2019 Fcffair BigData Resource, All rights reserved